首页 PHP小记laravel正文

低版本masql安装laravel的一些处理步骤

刘伟 laravel 2018-03-14 197 0

laravel框架,对于mysql的版本是有要求的,要求在5.7及以上版本的才可以 除了修改已安装mysql的版本之外,还有另外两种方式可以实现使用低版本的数据库 ①:找到对应的数据库配置文件,将数据库相关配置项中的charset对应的utf8mb4改成utf8,collation将utf8mb4_unicode_ci改成utf8_unicode_ci就可以了 ②:找到app目录下的Providers/AppServiceProvider.php文件,在这个类文件中的Boot方法内写一行代码也能完成数据迁移工作

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权发表,未经许可,不得转载。

评论